Critical WordPress Plugin Flaw Allows Complete Website Takeover

wordpress plugin zero day

Users of the popular plugin, Simple Social Buttons, are encouraged to update to version 2.0.22.

A critical vulnerability in popular WordPress plugin Simple Social Buttons enables non-admin users to modify WordPress installation options – and ultimately take over websites.

Simple Social Buttons enables users to add social-media sharing buttons to various locations of their websites. The plugin has more than 40,000 active installations, according to WordPress Plugin repository.

The flaw allows privilege escalation, so that non-admins can take over administrator accounts or even whole websites. This even includes the subscriber-user type, which has the most limited types of permissions (subscribers can read a website, post comments and create a profile – but they can’t edit settings or content on sites).

“Exploitation is fairly easy if the website allows public registrations, since the only requirement for an attacker to exploit this vulnerability is to have a registered user account,” Oliver Sild, founder and CEO of WebARX, told Threatpost. “It can be a low-privileged user whose only permission is to post a comment.”

Researchers with WebARX said on Monday that the vulnerability stems from two issues in Simple Social Buttons: Improper application design flow and a lack of permission checks.

These vulnerabilities allow any user type to change any option from the ‘wp_options’ database table, which is where the crucial configuration of a WordPress installation is located, Sild said.

“Improper application design flow, chained with lack of permission check resulted in privilege-escalation and unauthorized actions in WordPress installation allowing non-admin users, even subscriber user type to modify WordPress installation options from the wp_options table,” Luka Sikic, developer and researcher with WebARX, said in a Monday post.

At a technical level, the flaw allows a function to iterate through a JSON object provided in the request and update all options – without checking whether the current user has permission to manage options for the plugin. WebARX demonstrated the proof of concept (PoC) attack in a video (below).

From there, “there are multiple ways for an attacker to take over a whole website, or administrator account at least, just by modifying those configuration options,” Sild told Threatpost.

The vulnerability, which is rated 9.1 on the CVSS v3 severity scale, was discovered on Feb. 7, and a patch was released on Feb. 8. Users of the plugin are urged to update to version 2.0.22.

WordPress plugins continue to pose a security headache for site administrators. In fact, according to a January Imperva study, almost all (98 percent) of WordPress vulnerabilities are related to plugins that extend the functionality and features of a website or a blog.

In November, it was discovered that the popular AMP for WP plugin had a privilege-escalation flaw that allows WordPress site users of any level to make administrative changes to a website. And in January, researchers straight up urged WordPress site owners to delete a compromised plugin after multiple zero-day vulnerabilities were discovered being exploited by a malicious actor.

 

Suggested articles

Discussion

  • Fernandopoo on

    What is the world coming to when that last bastion of Security known as "Wordpress plugins" is found to have a flaw? WOE IS ME! #ShockAndAwe
  • Plugin Vulnerabilities on

    Instead of advising people to update a WordPress plugin after the details of a vulnerability fixed have been released, it would be better to advise people to keep their plugins up to date at all times, since you are not always even going to know that a security vulnerability has been fixed, much less is it going to get news coverage. What would be better to be covering are WordPress plugin vulnerabilities that haven't been fixed and are being exploited, since doing the security basic of keeping your software up to date won't protect websites and WordPress is failing to properly address unfixed vulnerabilities, so good coverage could be of great benefit.
  • Susan on

    This is why I'M glad to use the type of WordPress that doesn't require alot of work to be done with servers and plugins etc. Although the extra things available to those users are tempting,I'll stick to the dot com,not the dot org WordPress
  • scholarshipvigo.com on

    That is a great move, if am in your shoes I will also go for top custom domain. I think dot.com domain is the best of all

Leave A Reply to Plugin Vulnerabilities Cancel Reply

 

This site uses Akismet to reduce spam. Learn how your comment data is processed.

Subscribe to our newsletter, Threatpost Today!

Get the latest breaking news delivered daily to your inbox.