Mozilla has expanded its Plugin Check utility to support multiple web browsers.

According to Mozilla, a new cross-browser Plugin Check page now works with Firefox, Safari 4, Chrome 4, Opera 10.5 and Internet Explorer 7 and 8 for the most popular plugins (but since IE requires specific code to be written for each plugin, it will take a little longer to get to full coverage).

The Plugin Check tool is used to scan the browser for all installed plugins and provide one-click options to apply security patches if an outdated plugin is found. 

Mozilla’s Johnathan Nightingale has more information on the Plugin Check expansion.

Categories: Vulnerabilities, Web Security